and the vlan config seems a bit strange with the "0t" in vlan1.
However, looks like there's no wlan connection amoungst the nodes. Is
mentioned before, each direct neighbour is pingable without olsrd running.
Post by Chris W./etc/config/firewall
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'wlan'
option network 'wlan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
config forwarding
option src 'lan'
option dest 'wan'
config forwarding
option src 'wlan'
option dest 'wan'
config forwarding
option src 'lan'
option dest 'wlan'
config forwarding
option src 'wlan'
option dest 'lan'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option target 'ACCEPT'
option src 'wan'
option proto 'tcp'
option dest_port '22'
option include
option path '/etc/firewall.user'
/etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
config interface 'wan'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option ifname 'eth0.2'
option proto 'static'
option ipaddr '192.168.254.2'
option netmask '255.255.0.0'
option gateway '192.168.254.254'
option dns '10.4.0.1'
config switch
option name 'rtl8366rb'
option reset '1'
option enable_vlan '1'
option enable_vlan4k '1'
config switch_vlan
option device 'rtl8366rb'
option vlan '1'
option ports '0t 1 2 3 4 5t'
config switch_vlan
option device 'rtl8366rb'
option vlan '2'
option ports '0 5t'
config interface 'wlan'
option _orig_ifname 'wlan0'
option _orig_bridge 'false'
option proto 'static'
option ipaddr '10.5.0.1'
option netmask '255.255.0.0'
option broadcast '10.5.255.255'
/etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option macaddr 'f8:d1:11:56:8d:04'
list ht_capab 'SHORT-GI-40'
list ht_capab 'DSSS_CCK-40'
option channel '9'
option hwmode '11b'
option txpower '24'
option country 'BR'
config wifi-iface
option device 'radio0'
option encryption 'none'
option ssid 'wscmobile'
option mode 'adhoc'
option bssid 'f8:d1:11:56:8d:04'
option network 'wlan'
Here the output of this command
echo '/all' | nc localhost 2006
HTTP/1.0 200 OK
Content-type: text/plain
Table: Links
Local IP Remote IP Hyst. LQ NLQ Cost
Table: Neighbors
IP address SYM MPR MPRS Will. 2 Hop Neighbors
Table: Topology
Dest. IP Last hop IP LQ NLQ Cost
Table: HNA
Destination Gateway
0.0.0.0/0 <http://0.0.0.0/0> 10.5.0.1
Table: MID
IP address Aliases
Table: Routes
Destination Gateway IP Metric ETX Interface
only one of the routers is connected, so ta ouotros not appearing in the
command
but this not browsing
Att
Anderson Junior
Two more settings should be taken into account,
first is openwrt's firewall settings: forwarding between wan and
wifi should be enabled in /etc/config/firewall
config forwarding
option src wlan0
option dest wan
second is olsrd's HNA entry to announce the way out,
the olsrd_dyn_gw should take care about it. Check with
echo ""/all"" | nc localhost 2006, any "0.0.0.0/0
<http://0.0.0.0/0>" on the list?
btw. this is still without using smart gateway.
greetings,
Chris
hello, all devices are as adhoc and also with olsr running, my doubt is
now in gatwey settings that will provide internet, I'll post the
official list openwrt because I think it is an issue that refers to
openwrt, I believe qu must be a mistake to share the internet to the wan
wifi0
Att
Anderson Junior
Hi,
so you now have connectivity between all nodes, even if they are not
all in direct range (OLSR should forward the traffic hop by hip)?
Henning
On Thu, Feb 27, 2014 at 5:26 PM, ANDERSON JUNIOR GADO DA SILVA
Post by ANDERSON JUNIOR GADO DA SILVAhello, thanks for the help so far, the 3 devices are
talking to
each other,
Post by ANDERSON JUNIOR GADO DA SILVAwere with the ips so, 10.5.0.1, 10.5.0.2 and 10.5.0.3,
but still
no internet
Post by ANDERSON JUNIOR GADO DA SILVAconnection, I must choose one of openwrt and configure
the wan,
still do not
Post by ANDERSON JUNIOR GADO DA SILVAsee a way out in order to use pppoe authentication or
captive
(hotspot)
Post by ANDERSON JUNIOR GADO DA SILVAportal.
Att
Anderson Junior
Post by ANDERSON JUNIOR GADO DA SILVAHello,
an ip-bridge is not too useful with olsr,
the router's lan might be in a separate subnet which gets
announced via
Post by ANDERSON JUNIOR GADO DA SILVAPost by ANDERSON JUNIOR GADO DA SILVAolsrd.conf's HNA entry.
In this case all radios are in the 192.168.2.x subnet and
all lans are in 192.168.x.0/24 so the routing remains
simple.
Post by ANDERSON JUNIOR GADO DA SILVAPost by ANDERSON JUNIOR GADO DA SILVAconfig interface 'lan'
option ifname 'eth1'
option proto 'static'
option ipaddr '192.168.47.1'
option netmask '255.255.255.0'
config interface 'wlan0'
option proto 'static'
option ipaddr '192.168.2.47'
option netmask '255.255.255.0'
config wifi-iface
option device 'radio0'
option mode 'adhoc'
option ssid 'somename'
option bssid '00:10:20:30:40:70'
option network 'wlan0'
Good luck :)
Chris
On 02/27/2014 01:16 PM, ANDERSON JUNIOR GADO DA SILVA
Post by ANDERSON JUNIOR GADO DA SILVAHello, researching more about the ad-hoc mode, it does not
support so I
and now I'm
knowing now
that he
computer that
but already
the network
Post by ANDERSON JUNIOR GADO DA SILVAPost by ANDERSON JUNIOR GADO DA SILVAPost by ANDERSON JUNIOR GADO DA SILVAtopology?
Att
Anderson Junior
2014-02-27 4:07 GMT-04:00 Henning Rogge
On 02/26/2014 08:58 PM, ANDERSON JUNIOR GADO DA
Post by ANDERSON JUNIOR GADO DA SILVAGood afternoon, I was in doubt if I should
start a new
connected the
router and
wireless ad-hoc
access the
router,
Welcome.
should be able
to ping
wifi/interface
network
without
http://www.olsr.org/mediawiki/__index.php/First_Mesh___Troubleshooting
<http://www.olsr.org/mediawiki/index.php/First_Mesh_Troubleshooting>
Fraunhofer-Institut für
Ergonomie FKIE
<tel:%2B49%20228%209435-961> <tel:%2B49%20228%209435-961>
<tel:%2B49%20228%209435-961>, Fax +49 228
Post by ANDERSON JUNIOR GADO DA SILVAPost by ANDERSON JUNIOR GADO DA SILVAPost by ANDERSON JUNIOR GADO DA SILVA9435 685 <tel:%2B49%20228%209435%20685>
http://www.fkie.fraunhofer.de
--
Olsr-users mailing list
https://lists.olsr.org/__mailman/listinfo/olsr-users
<https://lists.olsr.org/mailman/listinfo/olsr-users>
Post by ANDERSON JUNIOR GADO DA SILVAPost by ANDERSON JUNIOR GADO DA SILVA--
Olsr-users mailing list
https://lists.olsr.org/__mailman/listinfo/olsr-users
<https://lists.olsr.org/mailman/listinfo/olsr-users>
Post by ANDERSON JUNIOR GADO DA SILVA--
Olsr-users mailing list
https://lists.olsr.org/__mailman/listinfo/olsr-users
<https://lists.olsr.org/mailman/listinfo/olsr-users>